Increased Match&Merged API & URL Lookup errors
Incident Report for Semantics3
Resolved
This incident has been resolved.
Posted about 2 years ago. Aug 03, 2017 - 00:56 UTC
Monitoring
Network connectivity issues with our upstream service provider
Posted about 2 years ago. Aug 03, 2017 - 00:51 UTC